Back to overview
Resolved

Semo.ai is down

Jun 26, 2026 at 10:06am UTC
Affected services
Semo.ai

Resolved
Jun 26, 2026 at 1:39pm UTC

Semo.ai recovered.

Updated
Jun 26, 2026 at 1:38pm UTC

Semo.ai is degraded.

Updated
Jun 26, 2026 at 10:08am UTC

Semo.ai recovered.

Created
Jun 26, 2026 at 10:06am UTC

Semo.ai is degraded.