Back to overview
Resolved

Semo.ai is down

Jun 27, 2026 at 7:33am UTC
Affected services
Semo.ai

Resolved
Jun 27, 2026 at 4:21pm UTC

Semo.ai recovered.

Updated
Jun 27, 2026 at 4:19pm UTC

Semo.ai is degraded.

Updated
Jun 27, 2026 at 3:01pm UTC

Semo.ai recovered.

Updated
Jun 27, 2026 at 2:59pm UTC

Semo.ai is degraded.

Updated
Jun 27, 2026 at 2:28pm UTC

Semo.ai recovered.

Updated
Jun 27, 2026 at 2:26pm UTC

Semo.ai is degraded.

Updated
Jun 27, 2026 at 2:22pm UTC

Semo.ai recovered.

Updated
Jun 27, 2026 at 2:20pm UTC

Semo.ai is degraded.

Updated
Jun 27, 2026 at 1:59pm UTC

Semo.ai recovered.

Updated
Jun 27, 2026 at 1:56pm UTC

Semo.ai is degraded.

Updated
Jun 27, 2026 at 1:48pm UTC

Semo.ai recovered.

Updated
Jun 27, 2026 at 1:46pm UTC

Semo.ai is degraded.

Updated
Jun 27, 2026 at 12:03pm UTC

Semo.ai recovered.

Updated
Jun 27, 2026 at 12:00pm UTC

Semo.ai is degraded.

Updated
Jun 27, 2026 at 9:27am UTC

Semo.ai recovered.

Updated
Jun 27, 2026 at 9:26am UTC

Semo.ai is degraded.

Updated
Jun 27, 2026 at 9:12am UTC

Semo.ai recovered.

Updated
Jun 27, 2026 at 9:11am UTC

Semo.ai is degraded.

Updated
Jun 27, 2026 at 9:08am UTC

Semo.ai recovered.

Updated
Jun 27, 2026 at 9:03am UTC

Semo.ai is degraded.

Updated
Jun 27, 2026 at 8:12am UTC

Semo.ai recovered.

Updated
Jun 27, 2026 at 8:11am UTC

Semo.ai is degraded.

Updated
Jun 27, 2026 at 7:35am UTC

Semo.ai recovered.

Created
Jun 27, 2026 at 7:33am UTC

Semo.ai is degraded.