Back to overview
Resolved

Semo.ai is down

Jun 28, 2026 at 6:43am UTC
Affected services
Semo.ai

Resolved
Jun 28, 2026 at 6:45am UTC

Semo.ai recovered.

Created
Jun 28, 2026 at 6:43am UTC

Semo.ai is degraded.