Back to overview
Resolved

Semo.ai is down

Jun 29, 2026 at 5:53am UTC
Affected services
Semo.ai

Resolved
Jun 29, 2026 at 6:00am UTC

Semo.ai recovered.

Updated
Jun 29, 2026 at 5:59am UTC

Semo.ai is degraded.

Updated
Jun 29, 2026 at 5:54am UTC

Semo.ai recovered.

Created
Jun 29, 2026 at 5:53am UTC

Semo.ai is degraded.